Back to overview
Degraded

Ion / Mail DNS Issues

Apr 26 at 07:17pm EDT
Affected services
Ion

Resolved
Apr 26 at 10:55pm EDT

The incident has been resolved. The issue was likely due to an expired DNSSEC key. Thank you for your patience.

Created
Apr 26 at 07:17pm EDT

We are investigating DNS lookup failures by major DNS providers when accessing CSL services including Ion and mail, causing them to be unreachable for some users. Other services remain available at this time. We apologize for the inconvenience as we work to resolve this issue.